admin管理员组

文章数量:1530013

Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 246    Accepted Submission(s): 205


题目链接:点击打开链接
Problem Description As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow.  n  players will take part in it. The  i th player’s strength point is  ai .

If there is a match between the  i th player plays and the  j th player, the result will be related to  |aiaj| . If  |aiaj|>K , the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After  n1  matches, the last player will be the winner.

Now, Yuta shows the numbers  n,K  and the array  a  and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  
 
Input The first line contains a number  t(1t100) , the number of the testcases. And there are no more than  2  testcases with  n>1000 .

For each testcase, the first line contains two numbers  n,K(1n105,0K<109) .

The second line contains  n  numbers  ai(1ai109) .
 
Output For each testcase, print a single line with a single number -- the answer.
Sample Input
2
5 3
1 5 9 6 3
5 2
1 5 9 6 3
 


Sample Output
5
1


题目意思:

给你一组n个数,代表n个选手的能量高低,现在再给你一个k,任意在n个选手中挑取两个选手比赛,如果 |ai−aj|>K那么能量高的选手获胜,另一个将被淘汰,否则两个人都有机会获胜,现在要你求有多少人有获胜的可能。



分析: 把所有人的能力从大到小排; 
能力最大的肯定可能拿冠军; 
然后一个一个地往后扫描; 
一旦出现a[i-1]-a[i]>k; 
则说明从这以后的人,都不可能再和有实力拿冠军的人竞争了 
无论怎么安排都赢不了那部分可能拿冠军的人. 


#include <iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int max1=100010;
int s[max1];
int main()
{
    int t,n,sum,k;
    scanf("%d",&t);
    while(t--)
    {
        sum=1;
        scanf("%d %d",&n,&k);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
        }
        sort(s,s+n);
        for(int i=n-1;i>0;i--)
        {
            if(s[i]-s[i-1]<=k)
            {
                sum++;
            }
            else
                break;
        }
        printf("%d\n",sum);
    }
    return 0;
}


本文标签: HDOJcompetitionRikka