admin管理员组

文章数量:1577820

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 

dijkstra求最短路径,考点,不求最短路径走向,不求最短距离值,求最短路径条数和点权和最大

其他的都很常规,但是注意此处起点和终点都是随机给定的,从哪边走向哪边并不确定,所以一定要建立成无向图(建立图时多加一句即可)

#include<iostream>
#include<algorithm>
using namespace std;

const int MAXV=510;
const int INF=1e9;
int n,m,s;//城市数 道路数 起点
int G[MAXV][MAXV],d[MAXV];
int weight[MAXV],w[MAXV]={0};//每个城市救援队数量   起点到点i距离最短的情况下最多的救援队数量w[i]初始化为0
int num[MAXV]={0};//num[i]表示起点s->i的最短路径数量 开始均为0
bool vis[MAXV]={false};

void Dijkstra(int s){
	//初始化
	fill(d,d+MAXV,INF);
	d[s]=0;
	w[s]=weight[s];
	num[s]=1;
	//循环n次
	for(int i=0;i<n;i++){
		int u=-1,MIN=INF;
		for(int j=0;j<n;j++){
			if(vis[j]==false&&d[j]<MIN){
				MIN=d[j];
				u=j;
			}
		}

		if(u==-1) return;
		vis[u]=true;
		for(int v=0;v<n;v++){
			if(vis[v]==false&&G[u][v]!=INF){
				if(d[u]+G[u][v]<d[v]){//距离第一优先权
					d[v]=d[u]+G[u][v];
					w[v]=w[u]+weight[v];
					num[v]=num[u];
				}else if(d[u]+G[u][v]==d[v]){
					w[v]=max(w[v],w[u]+weight[v]);
					num[v]+=num[u];
				}
			}
		}
	}

}

int main(){
	// freopen("input.txt","r",stdin);
	int end;//终点
	int u,v,dis;//u->v的距离是dis
	cin>>n>>m>>s>>end;
	for(int i=0;i<n;i++) cin>>weight[i];
	fill(G[0],G[0]+MAXV*MAXV,INF);//别忘记初始化了
	for(int i=0;i<m;i++){
		cin>>u>>v>>dis;//求确定两个城市的最短路径,绝对不会回头 但是起点和终点都是不确定的 所以建图时一定要建为无向图(万一求的是e->s 则要反过来走)
		G[u][v]=dis;
		G[v][u]=dis;//★★
	}
	Dijkstra(s);
	cout<<num[end]<<" "<<w[end];//最短路径数量和最多人手
	return 0;
}

 

 

本文标签: PATEmergency