admin管理员组

文章数量:1612099


A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 516    Accepted Submission(s): 267


Problem Description There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 
Input The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.
 
Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 
Sample Input
  
  
   
   2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
  
  
 
Sample Output
  
  
   
   Case #1: 2.00
Case #2: 5.00


   
   
    
    
     
     Hint
    
    
    
    In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

   
   
   
    
  
  
 
Source 2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题目链接:http://acm.hdu.edu/showproblem.php?pid=5112

题目大意:求每个相邻时间段内速度的最大值

题目分析:按时间排序,比较

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

struct Point
{
    int t, x;
}p[10005];

bool cmp(Point a, Point b)
{
    if(a.t == b.t)
        return a.x < b.x;
    return a.t < b.t;
}

int main()
{
    int T, n;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        double ans = 0;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%d %d", &p[i].t, &p[i].x);
        sort(p, p + n, cmp);
        for(int i = 0; i < n - 1; i++)
        {
            double tmp = abs(p[i + 1].x - p[i].x) * 1.0 / abs(p[i + 1].t - p[i].t);
            ans = max(tmp, ans);
        }
        printf("Case #%d: %.2f\n", ca, ans);
    }
}


 

本文标签: 北京curioushdu水题Matt