admin管理员组

文章数量:1648597

题目

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input

       
       
        
        1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
       
       
 

Sample Output

       
       
        
        0
1
2
2
       
       
 

题目的大体意思是寻找*将@分成了多少份,和池塘问题差不多,都是用深度搜索,就不多说了。

代码

#include<stdio.h>
int vis[110][110];
char a[110][110];
int m,n;
void dfs(int x,int y)
{
	if(x<0||x>=m||y<0||y>=n||vis[x][y]||a[x][y]=='*')
	return;
	vis[x][y]=1;
	dfs(x,y+1);
	dfs(x,y-1);
	dfs(x+1,y);
	dfs(x+1,y-1);
	dfs(x+1,y+1);
	dfs(x-1,y);
	dfs(x-1,y+1);
	dfs(x-1,y-1);
} 
main()
{
    int i,j;
    int f;
	while(scanf("%d%d",&m,&n)&&(m!=0||n!=0))
	{
		f=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				vis[i][j]=0;
			}
		}
		for(i=0;i<m;i++)
		scanf("%s",a[i]);

		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(!vis[i][j]&&a[i][j]=='@')
				{
					f++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",f); 
	}
}

深搜主要就是使用递归,其他就是注意细节问题。


本文标签: 石油OilDeposits