admin管理员组

文章数量:1530518

Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he’s a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it’s just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

Output
For each case output “Yes” if Crixalis can move all his equipment into the new hole or else output “No”.

Sample Input
2

20 3
10 20
3 10
1 7

10 2
1 10
2 11

Sample Output
Yes
No

这道题的关键是处理好sort排序排的是差值从大到小,差值越大所需的空间就越大。

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node {
	int x,y,z;
} a[1050];
int  cmp(node a1,node a2) {
	return a1.z>a2.z;
}
int main() 
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int flag=0;
		int v,n,sum=0;
		scanf("%d%d",&v,&n);
		for(int i=0; i<n; i++) 
		{
			scanf("%d%d",&a[i].x,&a[i].y);
			a[i].z=a[i].y-a[i].x;
		}
		sort(a,a+n,cmp);
		for(int i=0; i<n; i++) 
		{
			if(v>=a[i].y)
				v=v-a[i].x;
			else if(v<a[i].y||v<0) 
			{
				flag=1;
				break;
			}
		}
		if(flag==1)
			printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}

本文标签: hduequipmentCrixalis