admin管理员组

文章数量:1577816

1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4

这道题还是有些难度的,对于dijkstra算法要有一个比较清晰的认识,同时在进行时,维护两个数组,最短路径数组与最大人数数组,总的来说如果对dijkstra很熟悉是相当简单的

#include<bits/stdc++.h>
const int inf=99999999;
using namespace std;
int weight[1010];
int e[1010][1010];
int dis[1010];
bool visit[1010]={false};
int rode[1010];
int w[1010];
int main()
{
    fill(e[0],e[0]+1010*1010,inf);
    fill(dis,dis+1010,inf);
    int n,m,c1,c2;
    int a,b,c;
    cin>>n>>m>>c1>>c2;
    for(int i=0;i<n;i++){
        scanf("%d",&weight[i]);
    }
    for(int i=0;i<m;i++){
        cin>>a>>b>>c;
        e[a][b]=e[b][a]=c;
    }
    dis[c1]=0;
    rode[c1]=1;
    w[c1]=weight[c1];
    for(int i=0;i<n;i++){
        int minn=inf,u=-1;
        for(int j=0;j<n;j++){
            if(dis[j]<minn&&visit[j]==false){
                minn=dis[j];
                u=j;
            }
        }
        if(u==-1) break;
        visit[u]=true;
        for(int v=0;v<n;v++){
            if(dis[v]>dis[u]+e[u][v]&&visit[v]==false){
                dis[v]=dis[u]+e[u][v];
                rode[v]=rode[u];
                w[v]=w[u]+weight[v];
            }
            else if(dis[v]==dis[u]+e[u][v]&&visit[v]==false){
               rode[v]=rode[v]+rode[u];
               if(w[v]<w[u]+weight[v]){
                w[v]=w[u]+weight[v];
               }

            }
        }
    }
    cout<<rode[c2]<<" ";
    cout<<w[c2];
}

本文标签: 数组PATEmergencyDijkstra