admin管理员组

文章数量:1621906

描述

One day, boy A and girl B are playing a dice game. First, they write a number between 1~6 in a piece of paper, and then roll the dice. The one whose number is closer to the number of the dice will win this game. For example, A wins if |a-x|<|b-x|. And |a-x|=|b-x| means a draw.

输入

Each test case cantains two integers a and b, representing the numbers guessed by boy A and girl B respectively. The input is terminated in the end of file (EOF).

输出

For each test case, you must print the numbers of the cases of "A wins", "draw" and "B wins".

输入样例 1 

2 5

输出样例 1

3 0 3

输入样例 2 

2 4

输出样例 2

2 1 3

思路:

第一节课学的是暴力,所以遍历1~6,然后比较每个数与输入的数的绝对值之间的大小,用三个变量来记录赢的情况和平局情况,有一小点可以改进的就是这三个数相加一定是6,所以B赢的次数可以用6来减去A赢的次数和平局次数,就不用else多次判断了。

#include<iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
	int a, b;
	while (cin >> a && cin >> b)
	{
		int awin = 0, bwin = 0, draw = 0;
		for (int i = 1; i <= 6; i++)
		{
			if (abs(a - i) < abs(b - i))
				awin++;
			else if (abs(a - i) == abs(b - i))
				draw++;
		}
		bwin = 6 - awin - draw;
		cout << awin << " " << draw << " " << bwin << endl;
	}
	return 0;
}

本文标签: 算法思路代码北林OJ