admin管理员组

文章数量:1648618



 Oil Deposits Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
 

Sample Input

     
     
      
       1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
     
     
 

Sample Output

     
     
      
       0
1
2
2 
     
     
 


题目大意:

@表示油所在的区域,给出一块地图,有多少块区域。可以八个方向。

解题思路:

典型的搜索题,BFS  ,DFS 都可。


代码一  (BFS):

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<string>
#define N 110

using namespace std;

struct node{
    int x,y;
    node(int x0=0,int y0=0){//要写构造函数,不然下面用到时编译不通过.
        x=x0;y=y0;
    }
};

int directionX[8]={1,1,0,-1,-1,-1, 0, 1},n,m,cnt,x,y;
int directionY[8]={0,1,1, 1, 0,-1,-1,-1};
queue <node> path;
bool visited[N][N];
string map[N];

void bfs(node s){
    for(int i=0;i<8;i++){
        int dx=s.x+directionX[i],dy=s.y+directionY[i];
        if(0<=dx&&dx<n&&0<=dy&&dy<m){
             if(map[dx][dy]=='@'&&!visited[dx][dy]){
                visited[dx][dy]=true;
                path.push(node(dx,dy));
            }
        }
    }
        path.pop();
        if(path.size()>0)bfs(path.front());
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m)){
        cnt=0;
        memset(visited,false,sizeof(visited));
        while(!path.empty()) path.pop();
        for(int i=0;i<n;i++) cin>>map[i];
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                 if(map[i][j]=='@'&&!visited[i][j]){
                    visited[i][j]=true;
                    path.push(node(i,j));
                    cnt++;
                    bfs(path.front());
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


代码二(DFS):

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#define N 110

using namespace std;

struct node{
    int x,y;
    node(int x0=0,int y0=0){//要写构造函数,不然下面用到时编译不通过.
        x=x0;y=y0;
    }
};

int directionX[8]={1,1,0,-1,-1,-1, 0, 1},n,m,cnt,x,y;
int directionY[8]={0,1,1, 1, 0,-1,-1,-1};
bool visited[N][N];
string map[N];

void dfs(node s){
    for(int i=0;i<8;i++){
        int dx=s.x+directionX[i],dy=s.y+directionY[i];
        if(0<=dx&&dx<n&&0<=dy&&dy<m){
             if(map[dx][dy]=='@'&&!visited[dx][dy]){
                visited[dx][dy]=true;
                dfs(node(dx,dy));
            }
        }
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m)){
        cnt=0;
        memset(visited,false,sizeof(visited));
        for(int i=0;i<n;i++) cin>>map[i];
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                 if(map[i][j]=='@'&&!visited[i][j]){
                    visited[i][j]=true;
                    cnt++;
                    dfs(node(i,j));
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}



本文标签: 有多少原油区域hduPKu