admin管理员组

文章数量:1577814

题目链接:(PAT甲级)1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题解:看到这道题~最短路,直接用迪杰斯特拉来写,可是没有写对,一分都没得TT。。。

参考博文:https://wwwblogs/caiyishuai/p/9442367.html

#include <iostream>
#include <cstdio>
#include<cmath>
using namespace std;
const int maxn=510;
const int INF=0x3f3f3f3f;
int a[maxn],mp[maxn][maxn],dist[maxn],vis[maxn],way[maxn],sum[maxn];

int n,m,c1,c2;
void Dijkstra(){
	for(int i=0;i<n;i++){
		vis[i]=0;
		dist[i]=mp[c1][i];
		sum[i]=0;
		if(mp[c1][i]!=0&&mp[c1][i]!=INF){
			way[i]=1;	//i到c1最短路的条数 
			sum[i]=a[c1]+a[i]; i到c1路上途径的救援队的最大数量 
		}
	}
	vis[c1]=1;
	sum[c1]=a[c1];
	for(int i=1;i<n;i++){
		int tmp=INF,k;
		for(int j=0;j<n;j++){
			if(!vis[j]&&dist[j]<tmp){
				tmp=dist[j];
				k=j;
			}
		}
		
		if(tmp==INF) return ;
		vis[k]=1;
		for(int j=0;j<n;j++){
			if(!vis[j]&&dist[j]>dist[k]+mp[k][j]){
				dist[j]=dist[k]+mp[k][j];
				way[j]=way[k];
				sum[j]=sum[k]+a[j];
			}else if(!vis[j]&&dist[j]==dist[k]+mp[k][j]){
				way[j]+=way[k];
				sum[j]=max(sum[j],sum[k]+a[j]);
			}
			
		}
	}
	
}

int main(){
	while(~scanf("%d%d%d%d",&n,&m,&c1,&c2)){
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				mp[i][j]=(i==j?0:INF);
			}
		}
		int u,v,w;
		while(m--){
			scanf("%d%d%d",&u,&v,&w);
			mp[u][v]=mp[v][u]=min(mp[u][v],w);
		}
		Dijkstra();
		printf("%d %d\n",way[c2],sum[c2]);
	}
	return 0;
}

 

本文标签: PATEmergency