admin管理员组

文章数量:1612097

G - A Curious Matt Time Limit:2000MS    Memory Limit:512000KB    64bit IO Format:%I64d & %I64u Submit Status

Description

There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.  

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.  

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input

     
     
      
      2
3
2 2
1 1
3 4
3
0 3
1 5
2 0 
     
     
 

Sample Output

     
     
      
      Case #1: 2.00
Case #2: 5.00 
     
     

Hint

In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. 
The speed 5/1 is maximal. 



题意:给你n组时间以及对应时刻的位置,求整个过程中最大速度

思路:按照 时间从小到大排序,计算相邻时刻的速度,再求出最大值





#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
    int t,x;
}a[10005];
bool cmp(const node &a,const node &b)
{
    return a.t<b.t;
}
int main()
{
    int t;
    scanf("%d",&t);
    int j;
    for(j=1;j<=t;j++)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++)
            scanf("%d%d",&a[i].t,&a[i].x);
        sort(a,a+n,cmp);
        double maxn=0;
        for(i=1;i<n;i++)
        {
            if(1.0*(fabs(a[i].x-a[i-1].x))/(fabs(a[i].t-a[i-1].t))>maxn)
                maxn=1.0*(fabs(a[i].x-a[i-1].x))/(fabs(a[i].t-a[i-1].t));
        }
        printf("Case #%d: %.2lf\n",j,maxn);
    }
}





 

本文标签: curiousMatt