admin管理员组

文章数量:1612404

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
   
      There is a curious man called Matt.

   One day, Matt's best friend Ted is wandering on the non-negative half of the number line.  Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
  
  
 
Input
  
  
   
      The first line contains only one integer T, which indicates the number of test cases.

   For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

   Each of the following N lines contains two integers t
   
   i and x
   
   i (0 ≤ t
   
   i, x
   
   i ≤ 10
   
   6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t
   
   i would be distinct.
  
  
 
Output
  
  
   
      For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.

  
  
 
Sample Input
  
  
   
   2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
  
  
 
Sample Output
  
  
   
   Case #1: 2.00
Case #2: 5.00


   
   
    
    
     
     Hint
    
    In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

   
   
  
  
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
struct s
{
	int t,x;
}b[10010];
int cmp(const void *a,const void *b)
{
	return (*(struct s *)a).t-(*(struct s *)b).t;
}
int abs(int x)
{
	if(x<0)
		return -x;
	return x;
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		int n,i;
		double temp,max=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&b[i].t,&b[i].x);
		qsort(b,n,sizeof(b[0]),cmp);
		for(i=1;i<n;i++)
		{
			temp=abs(b[i].x-b[i-1].x)*1.0/(b[i].t-b[i-1].t);
			if(temp>max)
				max=temp;
		}
		printf("Case #%d: %.2lf\n",++c,max);
	}
}


本文标签: 赛区北京亚洲区curiousMatt