admin管理员组

文章数量:1612098

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3058    Accepted Submission(s): 1716


Problem Description There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.  

 

Input The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.  

 

Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.  

 

Sample Input 2 3 2 2 1 1 3 4 3 0 3 1 5 2 0  

 

Sample Output Case #1: 2.00 Case #2: 5.00 Hint In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.   水题,暴力 实现代码:
#include<bits/stdc++.h>
using namespace std;
const int M = 10000+50;
struct node{
    double t;
    double d;
}a[M];
bool cmp(const node &x,const node &y){
    return x.t < y.t;
}
int main()
{
    int t,i,n,j;
    while(scanf("%d",&t)!=EOF){
    for(j=1;j<=t;j++){
        scanf("%d",&n);
        for(i=1;i<=n;i++){
            scanf("%lf%lf",&a[i].t,&a[i].d);
        }
        sort(a+1,a+n+1,cmp);
        double ans;
        double maxx = 0;
        for(i=1;i<n;i++){
            ans = fabs(a[i+1].d - a[i].d)*1.0/fabs(a[i+1].t - a[i].t)*1.0;
            maxx = max(maxx,ans);
        }
        cout<<"Case #"<<j<<": ";
        printf("%.2lf\n",maxx);
    }
    }
}

 

转载于:https://wwwblogs/kls123/p/7895011.html

本文标签: 北京站亚洲区curioushduMatt