admin管理员组

文章数量:1648023

Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detectingunderground oil deposits. GeoSurvComp works with one large rectangularregion of land at a time, and createsa grid that divides the land into numerous square plots. It then analyzeseach plot separately,using sensing equipment to determine whether or not the plot contains oil.

A plot containingoil is called a pocket. If two pockets are adjacent, then they are part ofthe same oil deposit. Oildeposits can be quite large and may contain numerous pockets. Your job is todetermine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a linecontaining m and n, thenumber of rows and columns in the grid, separated by a single space. If m = 0 it signals the endof the input; otherwise and .Followingthis are m lines of n characterseach (not counting the end-of-line characters). Each character corresponds toone plot, and iseither ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two differentpockets are part of thesame oil deposit if they are adjacent horizontally, vertically, or diagonally.An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2

解决方案:dfs即可。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char Ma[110][110];
bool vis[110][110];
int n,m;
int sum;
void dfs(int a,int b)
{
     if(a>=0&&a<n&&b>=0&&b<m&&Ma[a][b]=='@'&&!vis[a][b])
     {
         vis[a][b]=true;
         dfs(a-1,b-1);dfs(a-1,b);dfs(a,b-1);dfs(a-1,b+1);
          dfs(a+1,b+1);dfs(a+1,b);dfs(a,b+1);dfs(a+1,b-1);
     }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=0;i<n;i++)
            scanf("%s",Ma[i]);
            memset(vis,false,sizeof(vis));
        sum=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
        {
            if(Ma[i][j]=='@'&&!vis[i][j])
            {
                sum++;
                dfs(i,j);
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}


本文标签: DepositsOilDFSuva