admin管理员组

文章数量:1577824

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1 and C​2 the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1 , c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​​ and C​2​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

思路:用DFS来查找出发点与目的地之间的最短距离,如果距离与最短相同,则path自增1,如果队伍数量大于total,就把值赋给total,最后输出path和total。

#include <bits/stdc++.h>
using namespace std;
#define MAX 505
int N,M,C1,C2;
int team[MAX],g[MAX][MAX],dist[MAX];
int path=0,total=0;
vector<int> v[MAX];
void dfs(int cp,int curl,int curteam)
{
	if(curl>dist[cp]) return;
	if(cp==C2)
	{
		if(curl==dist[C2])
		{
			path++;
			if(curteam>total) total=curteam;
		}
		else{
			dist[cp]=curl;
			path=1;
			total=curteam;
		}
	}
	else{
		if(curl<dist[cp]) dist[cp]=curl;
		for(int i=0;i<v[cp].size();i++)
		{
			int p=v[cp][i];
			dfs(p,curl+g[cp][p],curteam+team[p]);
		}
	}
}
int main()
{
	memset(dist,0x3f3f3f3f, sizeof dist);
	cin>>N>>M>>C1>>C2;
	for(int i=0;i<N;i++) cin>>team[i];
	int x,y,l;
	for(int i=0;i<M;i++)
	{
		cin>>x>>y>>l;
		v[x].emplace_back(y);
		v[y].emplace_back(x);
		g[x][y]=g[y][x]=l;
	}
	dfs(C1,0,team[C1]);
	cout<<path<<" "<<total;
	return 0;
}

本文标签: Emergency