admin管理员组

文章数量:1577548

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.


Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

中文大意

已知:N个城市M条路,每个城市都有救援⼩组,所有城市间道路的路长。
给定一个起点和终点
求解
result1:从起点到终点的最短路径的条数
result2:最短路径上救援⼩组数⽬之和的MAX


思路:

城市数量 :cityNum
路径数量 :  roadNum
城市A有key[A]个救援队
roadLen[城市A][城市B]=城市AB距离
result1:最短路径有几条,result2:最短路当中救援队最多的数量
vector<int> road[A] 记录 城市A联通的城市编号
appear[A]为动态规划数组,判断递归时城市A是否出现过
出现则跳过,没出现继续递归,递归完成后记得把appear[A]调整回false


C/C++ 

#include<bits/stdc++.h>
using namespace std;
// key记录城市救援队数量,roadLen记录俩城市间的距离
int cityNum,roadNum,head,tail,key[501],roadLen[501][501]={0};
long result1=0,result2=0,minRoadLength=9999999,a,b,c;
bool appear[501] = {false};
vector<int> road[501];

void findRoad(int now,long roadSumLength,long helpSum){
    helpSum += key[now];
    if(now==tail){
        if(roadSumLength<minRoadLength){
            minRoadLength=roadSumLength;
            result2 = helpSum;
            result1 = 1;
        }
        else if(roadSumLength==minRoadLength){
            result1 += 1;
            result2 = result2 > helpSum ? result2 : helpSum;
        }
        return;
    }
    appear[now] = true;
    for(int& x:road[now]) if(!appear[x]) {
//        cout << now << " -> " << x << endl;
        findRoad(x,roadSumLength+roadLen[now][x],helpSum);
    }
    appear[now] = false;
}

int main()
{

    cin >> cityNum >> roadNum >> head >> tail;
    for(int z=0;z<cityNum;z++) cin >> key[z];
    while (roadNum--) {
        cin >> a >> b >> c;
        road[a].push_back(b);
        road[b].push_back(a);
        roadLen[a][b] = c;
        roadLen[b][a] = c;
    }

    findRoad(head,0,0);

    cout << result1 << " " << result2;
    return 0;
}


本文标签: Emergency