admin管理员组

文章数量:1582954

Domination

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What’s more, he bought a large decorative chessboard withN rows andM columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard wasdominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

“That’s interesting!” Edward said. He wants to know the expectation number of days to make an empty chessboard ofN ×M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case: There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days. Any solution with a relative or absolute error of at most 10-8 will be accepted

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

题解

#include<bits/stdc++.h>
using namespace std;
const int maxn=51;
double dp[maxn*maxn][maxn][maxn];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		memset(dp,0,sizeof(dp));
		dp[0][0][0]=1;
		for(int i=0;i<=n*m;i++)
			for(int j=0;j<=n;j++)
				for(int k=0;k<=m;k++)
				{
					if((j==n&&k==m)||dp[i][j][k]==0)
						continue;
					if(i<j*k)
						dp[i+1][j][k]+=dp[i][j][k]*(j*k-i)/(n*m-i);
					if(j<n)
						dp[i+1][j+1][k]+=dp[i][j][k]*(n-j)*k/(n*m-i);
					if(k<m)
						dp[i+1][j][k+1]+=dp[i][j][k]*(m-k)*j/(n*m-i);
					if(j<n&&k<m)
						dp[i+1][j+1][k+1]=dp[i][j][k]*(n-j)*(m-k)/(n*m-i);
				}
		double ans=0;
		for(int i=0;i<=n*m;i++)
		{
			ans+=i*dp[i][n][m];
		}
		cout<<fixed<<setprecision(12)<<ans<<endl;
	}
}

详细
https://blog.csdn/chenzhenyu123456/article/details/47706085?utm_source=app

本文标签: 概率DominationDP