admin管理员组

文章数量:1616032

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones. 

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity. 

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters. 

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

题目大意及思路:给你n个字符串,让你求这n个字符串的最长公共子串,因为数据量范围不大,所以只需要对于第一个串去枚举所有的子串与剩下的字符串匹配即可。

/*
@Author: Top_Spirit
@Language: C++
*/
#include <bits/stdc++.h>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 4e3 + 10;
const int INF = 0x3f3f3f3f ;
const ull seed = 133 ;
const int MOD = 10007 ;
const double PI = acos(-1.0) ;
const int Max = 200 + 10 ;

char x[Max], ans[Max];
char f[Maxn][Max];
int Next[Max];

void strcpy1(char *y, int i, int len){
    for (int j = 0; j < len; i++,++j){
        x[j] = y[i];
    }
    x[len] = '\0';
}

void get_Next(char *s){
    int len = strlen(s);
    Next[0] = -1;
    int j = 0, k = -1;
    while (j < len){
        if (k == -1 || s[k] == s[j]){
            Next[++j] = ++k;
        }
        else k = Next[k] ;
    }
}

bool KMP (char *s, char *a){
    int ls = strlen(s),la = strlen(a);
    get_Next(a);
    int i = 0, j = 0;
    while (i < ls){
        if (j == -1 || s[i] == a[j]){
            i++, j++;
        }
        else j = Next[j];
        if (j >= la) return true ;
    }
    return false ;
}

int main (){
    int n;
    while (~scanf("%d",&n) && n){
        for (int i = 0; i < n; i++){
            scanf("%s",f[i]);
        }
        int len = strlen(f[0]);
        bool flag = false ;
        ans[0] = '\0' ;
        for (int i = len; i > 0 && !flag; i--){
            for (int j = 0; j <= len - i; j++){
                strcpy1(f[0],j,i);
                int k;
                for (k = 1; k < n; k++){
                    if (!KMP(f[k],x)){
                        break ;
                    }
                }
                if (k == n){
                    if (!flag || strcmp(ans,x) > 0){
                        strcpy(ans,x);
                        flag = true ;
                    }
                }
            }
        }
        if (flag) puts(ans);
        else puts("IDENTITY LOST");
    }
    return 0;
}

 

本文标签: IDENTITYCorporatehduKMP