admin管理员组

文章数量:1596328

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

一段数字,改变的方式是将某个区间内的数字开方,并且开方后还是整数。
不能用一般的延迟标记,因为这样的话就会之间在区间和上开方,题意是开方后求和,这样就会变成求和后开方。
但用朴素方法一定会超时,一个有效的提高效率的方法是当区间和正好等于区间长度时,说明这个区间里的数已经全部变成1,就不用再向下更新
这里有个很大的坑,就是给出的区间不一定是x

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 200005
#define Mod 10001
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn=222222;
long long sum[maxn<<2],mark[maxn<<2];
void PushUp(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    mark[rt]=0;
    if(r==l)
    {
        scanf("%I64d",&sum[rt]);
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void update(int L,int R,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=sqrt(sum[rt]);
        return;
    }
    if(L<=l&&r<=R&&sum[rt]==r-l+1)
        return;
    int m=(l+r)>>1;
    if(L<=m)
        update(L,R,lson);
    if(R>m)
        update(L,R,rson);
    PushUp(rt);
}
long long query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        return sum[rt];
    }
    int m=(l+r)>>1;
    long long ret=0;
    if(L<=m)
        ret+=query(L,R,lson);
    if(R>m)
        ret+=query(L,R,rson);
    PushUp(rt);
    return ret;
}
int main()
{
    //for(int i=1;i<=10;++i)
    //    cout<<i<<" "<<int(sqrt(i))<<endl;
    int n,m,cnt=1;
    while(~scanf("%d",&n))
    {
        build(1,n,1);
        scanf("%d",&m);
        int t,x,y;
        printf("Case #%d:\n",cnt++);
        while(m--)
        {
            scanf("%d%d%d",&t,&x,&y);
            if(y<x)
                swap(x,y);
            if(t==0)
            {
                update(x,y,1,n,1);
            }
            else
                printf("%I64d\n",query(x,y,1,n,1));
        }
        printf("\n");
    }
    return 0;
}

本文标签: 线段区间answerQueries