admin管理员组

文章数量:1616032

题目描述:

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

输入:

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

输出:

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

样例输入:

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

样例输出:

abb
IDENTITY LOST

code:

题目大意:其实就是求一组字符串的最长公共子字符串。
暴力+KMP

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
char a[4000][500];
char b[500];
int nextt[500];
vector<string> feng;
void init()
{
	int i=0,j=-1;
	nextt[0]=-1;
	int m=strlen(b);
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{
			i++;
			j++;
			nextt[i]=j;
		}
		else
		{
			j=nextt[j];
		}
	}
}
bool kmp(int what)
{
	int i=0,j=0;
	int flag=0;
	init();
	int n=strlen(a[what]);
	int m=strlen(b);
	while(i<n)
	{
		if(j==-1||a[what][i]==b[j])
		{
			j++;
			i++;
		}
		else j=nextt[j];
		if(j==m)
		{
			return true;
		}
	}
	return false;
}
bool cmp(string a,string b)
{
	return a<b;
}
int main()
{
	int ttt,n;
	while(scanf("%d",&n)&&n)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%s",a[i]);
		}
		int m=strlen(a[0]);
		int flag=0;
		int much;
		int sum=0;
		for(int i=0;i<=m;i++)
		{
			for(int j=0;j<=i;j++)
			{
				int start=j,over=m-i+j-1;
				memset(b,'\0',sizeof(b));
				int qq=0;
				for(int k=start;k<=over;k++)
				{
					b[qq++]=a[0][k];
				}
				int jie=1;
				for(int k=1;k<n;k++)
				{
					if(!kmp(k))
					{
						jie=0;
						break;
					}
				}
				if(jie==1)
				{
					flag=1;
					feng.push_back(b);
				}
			}
			if(flag||i==m)break;
		}
		if(strlen(b)==0)printf("IDENTITY LOST\n");
		else 
		{
			sort(feng.begin(),feng.end(),cmp);
			cout<<feng[0]<<endl;
		}
		feng.clear();
	}
	return 0;
}

本文标签: CorporateIDENTITY